Skip to content

solving arch linux error message: ":: installing pacman (5.2.1-1) breaks dependency 'pacman<=5.1.3' required by yay"

If you get the error message below, there are easy steps you have to do to fix this.

:: installing pacman (5.2.1-1) breaks dependency 'pacman<=5.1.3' required by yay
  • yay -S yay-bin
  • sudo pacman -Syy
  • sudo pacman -S pacman
  • yay -Syyu

So all in all, you will replace yay with yay-bin since yay-bin is newer and supports latest pacman. Afterwards, you are updating your database followed by updating pacman to the latest version. Finally, you will do your regular system update maintenance.

Translate to de es fr it pt ja

Categories: os
Defined tags for this entry: , ,
Vote for articles fresher than 7 days!
[0] 38 hits

How to update your arch linux without the kernel

If you are using archzfs and the zfsonlinux, you know that it can happen from time to time that you have to wait until packages are updated to the newest kernel (or lts kernel). Whenever you want to upgrade your system, you get an error like the following.

:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: spl-linux-lts: installing linux-lts (4.9.32-1) breaks dependency 'linux-lts=4.9.30'
:: zfs-linux-lts: installing linux-lts (4.9.32-1) breaks dependency 'linux-lts=4.9.30'
:: zfs-utils-linux-lts: installing linux-lts (4.9.32-1) breaks dependency 'linux-lts=4.9.30'

To update your system without the kernel (and its dependencies), you can use the following trick.

#example if you use the lts kernel
#if you use plain pacman
pacman -Syyu --ignore=linux-lts,linux-lts-headers
#if you use pacaur
pacaur pacman -Syyu --ignore=linux-lts,linux-lts-headers

Thats it :-).

Translate to de es fr it pt ja

arch linux, zfsonlinx with pacman update producing error >>error: demz-repo-core: signature from "graysky (used to sign repo-ck packages) <[email protected]>" is unknown trust<<

You tried to do an update of your system and got some error like below?

pacman -Syyu
error: demz-repo-core: signature from "graysky (used to sign repo-ck packages) graysky@archlinux.us" is unknown trust
:: Synchronizing package databases...
[...]
error: demz-repo-core: signature from "graysky (used to sign repo-ck packages) graysky@archlinux.us" is unknown trust
error: failed to update demz-repo-core (invalid or corrupted database (PGP signature))
[...]
error: database 'demz-repo-core' is not valid (invalid or corrupted database (PGP signature))


You can read the comments if you want to know why.
If you are easy enough and believe me (well thanks, but you shouldn't ;-)), execute the following commands.
pacman-key -r 5EE46C4C
pacman-key --lsign-key 5EE46C4C
echo i like artodeto
pacman -Syyu


And there you go.

Translate to de es fr it pt ja